Upgrade fails when upgrading from version 10.2 or older

 

SUMMARY

When upgrading from version 10.2 or earlier, the upgrade process fails due to a dependency issue with the mono package. This issue only impacts system running on CentOS 6 which are running a dated release.

The update failure results will look similar to this:

upgrade_mono_failure.JPG

 

ISSUE

Older versions of the Linux mono package create dependency issues preventing the update of the mono package. This issue prevents the 10.4.10 upgrade from completing successfully.

To confirm this issue, use the rpm -qa command to identify the version of the Linux mono package installed. Mono version 4.8 is the problematic package version.

[[email protected] ~]# rpm -qa | grep mono
mono-winforms-4.8.0-7.el6.x86_64
mono-core-4.8.0-7.el6.x86_64
dejavu-lgc-sans-mono-fonts-2.30-2.el6.noarch
mono-data-sqlite-4.8.0-7.el6.x86_64
mono-extras-4.8.0-7.el6.x86_64
mono-web-4.8.0-7.el6.x86_64
mono-wcf-4.8.0-7.el6.x86_64
dejavu-sans-mono-fonts-2.30-2.el6.noarch
mono-data-4.8.0-7.el6.x86_64
mono-mvc-4.8.0-7.el6.x86_64

[[email protected] ~]# dpu version
Unitrends' DPU Kernel 2.6.32-573.26.1.el6.x86_64
Version 10.2.0-1.201806180102.CentOS6
Installed on Tue 19 Jun 2018 07:27:59 AM IST

 

RESOLUTION

To complete the upgrade, the system must first be upgraded to version 10.4.9 following the Air Gap upgrade process.

  1. First, download the version 10.4.9 upgrade media here: Release 10.4.9 for CentOS6 upgradeDVD (md5).
  2. Next, using the air gap update steps, upgrade the system to version 10.4.9. Follow this KB using the upgrade media downloaded in step 1: How to upgrade the appliance via Unitrends' media (Air Gap / Offline updates)
  3. Once the system has been upgraded to 10.4.9, subsequent upgrades can be performed following the standard update process. For more information, see How do I update the appliance? 
Was this article helpful?
0 out of 0 found this helpful
Have more questions? Contact us