Update fails with "ERROR with rpm_check_debug vs depsolve:"

 

ISSUE

 

When attempting to upgrade the Unitrends Backup software, the upgrade fails with the error "ERROR with rpm_check_debug vs depsolve:"

 

ERROR with rpm_check_debug vs depsolve:
system-logos is needed by plymouth-0.8.3-29.el6.centos.x86_64
system-logos >= 7.92.1-1 is needed by httpd-2.2.15-69.el6.centos.x86_64
system-logos is needed by grub-1:0.97-99.el6.x86_64
** Found 5 pre-existing rpmdb problem(s), 'yum check' output follows:
1:grub-0.97-83.el6.x86_64 has missing requires of system-logos
httpd-2.2.15-54.el6.centos.x86_64 has missing requires of system-logos >= ('0', '7.92.1', '1')
plymouth-0.8.3-27.el6.centos.x86_64 has missing requires of system-logos
unitrends-release-6-5.el6.11.17.x86_64 has installed conflicts redhat-release: unitrends-release-6-5.el6.11.17.x86_64
unitrends-release-6-5.el6.11.17.x86_64 has installed conflicts centos-release: unitrends-release-6-5.el6.11.17.x86_64
Your transaction was saved, rerun it with: yum load-transaction /tmp/yum_save_tx-2020-08-31-17-41JUdUJt.yumtx

 

This indicates that there is likely a dependency issue with one of the packages previously installed.

This issue is seen on CentOS 6 based systems.

 

RESOLUTION

 

    1. First, use the Unitrends_CLI to attempt the upgrade. While this is likely to experience the same error, you may find additional information to assist with troubleshooting the error. For more detailed instructions, follow the steps in How to safely update the Unitrends appliance from the SSH Command Line Interface.

    2. If the error persist, the missing package will need to be installed. In this case, system-logos should be installed.
      system-logos is needed by plymouth-0.8.3-29.el6.centos.x86_64
    3. To install the missing package, run the command below replacing 'system-logos' with the package needed.
      yum install system-logos

* WARNING: Never run 'yum install' or 'yum update' without specifying the exact package required. Do so may result in a loss of functionality and/or data. If assistance is needed, please consult Unitrends Support.

 

NOTES

Additional information may be found through Red Hat here: https://access.redhat.com/solutions/739793

 

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Contact us