CVE-2011-3607 httpd: ap_pregsub Integer overflow to buffer overflow

CVE ID

CVE-2011-3607

DESCRIPTION

Integer overflow in the ap_pregsub function in server/util.c in the Apache HTTP Server 2.0.x through 2.0.64 and 2.2.x through 2.2.21, when the mod_setenvif module is enabled, allows local users to gain privileges via a .htaccess file with a crafted SetEnvIf directive, in conjunction with a crafted HTTP request header, leading to a heap-based buffer overflow.

Unitrends risk assessment: None with security updates

RESOLUTION

For CentOS6, fixed in httpd-2.2.15-15.el6_2.1 or later and
Unitrends systems have httpd-2.2.15-54.el6 or later which has the fix.

LINK TO ADVISORIES

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Contact us