CVE-2015-8325: openssh privilege escalation via LD_PRELOAD

SUMMARY

Resolved with later openssh rpm in security update.

CVE ID

CVE-2015-8325

DESCRIPTION

The do_setup_env function in session.c in sshd in OpenSSH through 7.2p2, when the UseLogin feature is enabled and PAM is configured to read .pam_environment files in user home directories, allows local users to gain privileges by triggering a crafted environment for the /bin/login program, as demonstrated by an LD_PRELOAD environment variable.

RESOLUTION

Fixed in openssh-5.3p1-122.el6 with Unitrends security updates from 04/25/2017 and later.

LINK TO ADVISORIES

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Contact us