CVE-2016-10009 openssh: loading of untrusted PKCS#11 modules in ssh-agent

CVE ID

CVE-2016-10009

DESCRIPTION

It was found that ssh-agent could load PKCS#11 modules from arbitrary paths. An attacker having control of the forwarded agent-socket on the server, and the ability to write to the filesystem of the client host, could use this flaw to execute arbitrary code with the privileges of the user running ssh-agent.



 

RESOLUTION

Red Hat Statement: In order to exploit this flaw, the attacker needs to have control of the forwarded agent-socket and the ability to write to the filesystem of the host running ssh-agent. Because of this restriction for successful exploitation, this issue has been rated as having Moderate security impact. A future update may address this flaw.

CentOS6    openssh    - Will not fix
CentOS7    openssh    - Use openssh-7.4p1-11.el7.x86_64.rpm

LINK TO ADVISORIES

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Contact us