DCA job reports VMware Tools are not installed

SUMMARY

DCA jobs reports VMware Tools are not installed even though they are.

ISSUE

During the course of a DCA job to VMware VMIR tasks may report "VMware Tools are not installed".

RESOLUTION

Update to VMware tools 10.2.1 or higher on the effected production machine then run a new backup.
We know that VMware tool 10.2.1 resolves the issue but anything that is 10.0.9 or below is susceptible to this behavior.

VMware KB to updating VMware tools in vSphere:
https://kb.vmware.com/s/article/2004754




 

CAUSE

This is caused by VMware tools not responding to the host correctly.

NOTES

Note VMWare tools 10.2.1 requires esxi 5.5 or higher.  CDM may not work reliably on older VMWare editions due to this VMWare defect.  

When upgrading vmware tools, vms should also be updated to the latest supported VM hardware version supported by the ESXi edition.  Unitrends recommends all VMs always be on the latest hardware edition for your hypervisor as restores of VMs are automatically up-converted by VMWare outside of Unitrends control, which could result in boot compatibility problems after restore.  If you have not already updated to the latest VM platform hardware version available to you, please do so at your first opportunity.  Note, after a platform change, new full backups are required which may also require new VM replicas to be recreated.  If you are using Unitrends Forever Cloud with Elite or Premium DRaaS options, please notify Unitrends Support if you change a Vm hardware version in production.  Make this notification after you have preformed your new full backup and you have successfully completed replication of the new full to the cloud.  

Unitrends and VMWare recommend your ESXi build release also be current to a release.  VMWare tools 10.2.1 were released consistent with 5.5 U3h build 7967571, ESXi 6.0 U3e build 7967664, and 6.5 U2 build 8294914.  If you are using a lower esxi build, unitrends and VMWare recommend you update that as well.  VMWare is continually locating and fixing critical CBT or disk consolidation issues and running on an older vmware build has been shown to leave some syste backups unrecoverable due to defects in VMWare's own code.  Your VM hosts should be updated frequently as part of both security and functional compatibility maintenance efforts.  

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Contact us