Error when Installing Linux Agent - CENTOS8

SUMMARY

These are the dependencies needed to get the linux agent installed on CENTOS 8 if you are getting errors on failed dependencies.

ISSUE

Missing dependencies when installing the Linux Agent On CENTOS 8 servers.
 

[[email protected] ~]# rpm -ivh unitrends-linux-agent-10.3.10-1.201909171429.x86_64.rpm
error: Failed dependencies:
        libc.so.6 is needed by unitrends-linux-agent-10.3.10-1.201909171429.x86_64
        libc.so.6(GLIBC_2.0) is needed by unitrends-linux-agent-10.3.10-1.201909171429.x86_64
        libc.so.6(GLIBC_2.1) is needed by unitrends-linux-agent-10.3.10-1.201909171429.x86_64
        libc.so.6(GLIBC_2.2) is needed by unitrends-linux-agent-10.3.10-1.201909171429.x86_64
        libcrypto.so.6()(64bit) is needed by unitrends-linux-agent-10.3.10-1.201909171429.x86_64
        libmenu.so.5()(64bit) is needed by unitrends-linux-agent-10.3.10-1.201909171429.x86_64
        libncurses.so.5()(64bit) is needed by unitrends-linux-agent-10.3.10-1.201909171429.x86_64
        libwrap.so.0()(64bit) is needed by unitrends-linux-agent-10.3.10-1.201909171429.x86_64
[[email protected] ~]#
 
[[email protected] ~]# yum install  unitrends-linux-agent-10.3.10-1.201909171429.x86_64.rpm
Last metadata expiration check: 3:43:43 ago on Fri 17 Jan 2020 01:34:54 AM EST.
Error:
 Problem: conflicting requests
  - nothing provides libcrypto.so.6()(64bit) needed by unitrends-linux-agent-10.3.10-1.201909171429.x86_64
  - nothing provides libwrap.so.0()(64bit) needed by unitrends-linux-agent-10.3.10-1.201909171429.x86_64
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)
 
[[email protected] cnt_script-10_3_10]# ./lnx64_cnt
Verifying archive integrity... All good.
Uncompressing Unitrends Linux Agent....

You must install the package that provides a 64-bit version of libmenu.so.5
You must install the package that provides a 64-bit version of libncurses.so.5
We are creating a sym link for libssl.so.6 for you at /lib64/libssl.so.6.
We are creating a sym link for libcrypto.so.6 for you at /lib64/libcrypto.so.6.
You must install the package that provides a 64-bit version of libwrap.so.0

Dependencies for Unitrends Agent must be installed before proceeding with installation.


 

RESOLUTION

When you see the errors above do the following. 

Step 1. 

wget https://rpmfind.net/linux/centos/7.7.1908/os/x86_64/Packages/openssl098e-0.9.8e-29.el7.centos.3.x86_64.rpm

Then you will run 

yum install openssl098e-0.9.8e-29.el7.centos.3.x86_64.rpm
Step 2
wget https://rpmfind.net/linux/centos/7.7.1908/os/x86_64/Packages/tcp_wrappers-libs-7.6-77.el7.x86_64.rpm

Then you will run

yum install tcp_wrappers-libs-7.6-77.el7.x86_64.rpm

 Then you can go ahead and proceed with trying the install of the agent again.
 

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Contact us