SharePoint farm backup job failed, no client messages present

SUMMARY

SharePoint 2010 or 2013 farm backup job failed, no client messages present

ISSUE

SharePoint backup fails due user credentials not set correctly

SharePoint 2010, 2013 or 2016 farm backup job failed, no client messages present

Command Failed: Verifying SharePoint User Credentials
----- Client Messages -----
----- End Client Messages -----

RESOLUTION

  1. Create domain account 'domain\SP2013': password never expire
  2. Add the account 'domain\SP2013' to local administrators group
  3. Give the account 'domain\SP2013' the rights to log on as a service:
    1. Select Control Panel > Administrative Tools
    2. Select Local Security Policy > Local Policies >User Rights Assignment.
    3. Right-click Log on as a service and select Security or Properties.
    4. Click Add to add the account on which the Executive Viewer service is running on.
    5. For a domain account the Domain Security Policy has to be adjusted.
  4. After that the message in summary output will be:
    Object reference not set to an instance of an object.
  5. Add 'domain\SP2013' account to be a 'Member of Farm Administrators SharePoint group'
    1. Login as SharePoint administrator to the client
    2. Click Microsoft SharePoint 2013 Products.
    3. Click SharePoint 2013 Management Shell.
    4. At the Windows PowerShell command prompt, type the following command:
      Add-SPShellAdmin -UserName domain\SP2013

CAUSE

User credentials are not valid

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Contact us