Boomerang allows me to replicate a VM but it fails to deploy.

SUMMARY

Boomerang deploy failure causes.

ISSUE

Boomerang virtual machine deploy fails.  This generally presents as failure due to timeout.

RESOLUTION

It is not possible to understand exactly why a given virtual machine is not booting up.  The following are things we have found to cause deployment failure:
 

For AWS deployments Amazon has a list of issues which will cause the image import to fail: http://docs.aws.amazon.com/vm-import/latest/userguide/vmimport-troubleshooting.html. A notable cause mentioned there is a P2V or physical to virtual conversion.

The Windows virtual machine has Hyper-V configured.  AWS/Azure do not support nested virtualization and Hyper-V machines will bootloop with crashes without hardware virtual support.

Your virtual machine has a hard disk on the IDE controller.  Move the disk to a different controller and replicate a new snapshot to resolve this.

CAUSE

Boomerang gathers information from vSphere to determine whether a VM is supported by AWS or not.  Boomerang is designed to be non-intrusive and we do not look into your VMs for additional information.  As a result, certain incompatibility issues can only be detected after a “Deployment” action.  We strongly recommend our users to test their recovery plan (deployment) on a regular basis.

NOTES

For AWS, sometimes a deployment failure cause can be ascertained by querying Amazon as follows:

  1. Install the AWS CLI: https://aws.amazon.com/cli/
  2. Run "aws configure" and enter the appropriate credential and region information
  3. Run "aws ec2 describe-import-image-tasks --import-task-id import-ami-xxxxxxx".  Your task id can be found in the deployment details.

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