CVE-2011-4317 httpd: uri scheme bypass of the reverse proxy vulnerability

CVE ID

CVE-2011-4317

DESCRIPTION

The mod_proxy module in the Apache HTTP Server 1.3.x through 1.3.42, 2.0.x through 2.0.64, and 2.2.x through 2.2.21, when the Revision 1179239 patch is in place, does not properly interact with use of (1) RewriteRule and (2) ProxyPassMatch pattern matches for configuration of a reverse proxy, which allows remote attackers to send requests to intranet servers via a malformed URI containing an @ (at sign) character and a : (colon) character in invalid positions. NOTE: this vulnerability exists because of an incomplete fix for CVE-2011-3368.

Unitrends risk assessment:  None (no mod_proxy module loaded)

RESOLUTION

For CentOS6, this issue was fixed in httpd-2.2.15-15.el6_2.1
Unitrends security updates have httpd-2.2.15-54.el6 or later which contains the fix.

LINK TO ADVISORIES

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Contact us