CVE-2016-10012 openssh: Bounds check evaded in shared memory manager with pre-authentication compression support

CVE ID

CVE-2016-10012

DESCRIPTION

It was found that the boundary checks in the code implementing support for pre-authentication compression could have been optimized out by certain compilers. An attacker able to compromise the privilege-separated process could possibly use this flaw for further attacks against the privileged monitor process.

In order to exploit this flaw, the attacker needs to first compromise the sandboxed privilege-separation process by using another security flaw. Because of this restriction for successful exploitation, this issue has been rated as having Low security impact. A future update to Red Hat Enterprise Linux 7 will address this flaw.

RESOLUTION

CentOS6    openssh    - Will not fix
CentOS7    openssh    - Use openssh-7.4p1-11.el7.x86_64.rpm

LINK TO ADVISORIES

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Contact us