CVE-2016-2107: OpenSSL oracle padding vulnerability

CVE ID

CVE-2016-2107

DESCRIPTION

The AES-NI implementation in OpenSSL before 1.0.1t and 1.0.2 before 1.0.2h does not consider memory allocation during a certain padding check, which allows remote attackers to obtain sensitive cleartext information via a padding-oracle attack against an AES CBC session, NOTE: this vulnerability exists because of an incorrect fix for CVE-2013-0169.

Unitrends risk assessment:  High
 

RESOLUTION

For CentOS5, not vulnerable
For CentOS6, resolved in openssl-1.0.1e-48.el6_8.1

This openssl update resolves the following CVEs:
    CVE-2016-0799, CVE-2016-2105, CVE-2016-2106, CVE-2016-2107
    CVE-2016-2108, CVE-2016-2109, CVE-2016-2842

To apply the fix, download the latest Unitrends security update from the ftp site.


 

LINK TO ADVISORIES

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Contact us