Upgrade attempt fails because appliance cannot download update packages

SUMMARY

Upgrade attempt fails because appliance cannot download update packages

ISSUE

In some instances, upgrade attempts might fail because your appliance (physical or virtual) cannot download update packages from the Unitrends repository.


 

 

RESOLUTION

Ensure port 21 (FTP), 80 (HTTP), and 443 HTTPS) are ALL accessible outgoing through your firewall for the Unitrends Appliance. With release 10.4 and higher, ALL THREE protocols are required.  Options to limit to one port or protocol no longer apply.  

If you would like to restrict this communication to specific trusted URLs, please see our KB What Firewall Ports should be allowed from the Unitrends appliance through my firewall?

CAUSE

The upgrade fails because a firewall or network restriction is preventing the appliance from reaching the Unitrends website on required ports or protocols.  

Unitrends appliances use multiple sites and several ports to complete update operations which must be open between the appliance and the internet through your firewall.  

NOTES

Additional information below is LEGACY and applies only to appliances running releases prior to 10.x.  

You can resolve this issue by downloading the packages using a different transfer protocol.  If the appliance is attempting to download the packages from the HTTP site, download from the FTP site instead, or vice versa.

Warning:  This procedure is for advanced users online.

On appliances running 9.1 or newer:

From the command line, run "dpu repo proto ftp" or "dpu repo proto http" to change protocols. 

On appliances running 9.0-15 or older:

  1. Use an SSH client such as PuTTY to access the Unitrends system at the command line level.
    Note:  Ensure you have the OS password to access the Unitrends system’s command line.  The OS password may differ from the password used to access the User Interface.
  2. Enter the following command: vi /etc/yum.repos.d/Unitrends-RecoveryOS.repo
  3. Press the Insert key.
  4. Look for the following lines:

 include=ftp://updateftp.unitrends.com/pub/Unitrends-RecoveryOS-5-x86_64.repo

 include=http://updateftp.unitrends.com/pub/Unitrends-RecoveryOS-5-x86_64.repo

  1. You see a # symbol in front of the line for the transfer protocol the appliance is currently using.  To change the transfer protocol, delete the # symbol from the current line and add one to the line for the other transfer protocol.

Note: There must be a # symbol in front of one of these lines.  If neither line has a # symbol, all update attempts will fail.

  1. Press the ESC key.
  2. Run wq to save the new setting.
  3. Run yum clean all
  4. Return to the Administrator Interface, and upgrade the system by selecting the Options menu (Gears icon at top right) > Check for Updates.

If neither HTTP or FTP protocols allow for a successful upgrade, then you may be on a closed network and will need to contact Unitrends Support to acquire physical update media.

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Contact us