Update that use FTP may fail.

SUMMARY

Low update, download timeout, or cannot download updates or required Support scripts because the process uses Passive FTP (aka PASV). yum wget

ISSUE

The Unitrends system is configured to access the Unitrends repository over HTTP by default.  The system may be re-configured to update over FTP by following Upgrade attempt fails because appliance cannot download update packages.  When connecting to the Unitrends repository yum fails to retrieve the repo file.

RESOLUTION

Using PuTTY or another SSH client connect to the Unitrends system as the root user and run the following:

find / -name ftplib.py -exec sed -i 's/passiveserver = 1/passiveserver = 0/g' {} \;

Updates should now succeed.


When using wget, you can use the option of --no-passive-ftp to force the download to occur over Active FTP mode

CAUSE

Yum uses http in our configuration. If you have to force yum to use ftp, you might have issues. Those issues might be caused by yum using ftp in passive mode. Active mode should be the answer. You will need to configure yum to use ftp in active mode.

yum is configured to operate in passive mode over FTP.  This configuration may return the following error message when updating via CLI.

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Contact us