Invalid Google Storage API credentials. Google legacy Interoperable Storage API: 'Access Key' and 'Secret Key'. on 10.1.1-3

SUMMARY

Unable to add a new Google Cloud bucket to a Unitrends Appliance

ISSUE

On a Unitrends appliance, you get the following error when trying to add a Google Nearline account for use with Cold Copy archiving:

Invalid Google Storage API credentials. Google legacy Interoperable Storage API: 'Access Key' and 'Secret Key'.

You have verified your Access Key and Secret Key are in fact correct.  

RESOLUTION

Google's API for their secure key changed from 20 bytes to now 24 bytes without advanced vendor notice.  
Unitrends has changed our CloudHook package to support the updated byte string, but, this package is not included in our currently shipping releases.  It will need to be manually applied to your system by a Unitrends Customer Engineer.

Please contact Unitrends Technical Support for an important update to allow for the new API changes.

Your appliance must be running release 10.1.1-3 or 10.2.0 before this patch can be applied by our support team.  

TASKS

Please contact Unitrends Technical Support by telephone or by using your customer portal to create a new case. 
Please note, Patches may not be applied to assets with standard support as phone or escalated assistance may be required.  A support contract including phone support must be active on your asset to receive out-of-band software patches.  

 

NOTES

This issue will be resolved in release 10.3.x due out in Q4 2018 and will not require hotfixes for this issue after that point.  

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Contact us